• Mystic message linking

    From g00r00@46:1/127 to Gryphon on Tuesday, April 12, 2016 15:02:38
    The logs don't show which messages were linked with which. It only
    shows how many messages were linked.

    Okay so you are saying it shows them linked in the logs but they're not
    linked in the message bases?

    There is no quick_link=false.
    Ok, I guess this changd from 1.12a7?

    Not sure what version but I'm sure its all in the WHATSNEW.

    BUT, it appears for my case, from my logs, that the ImportEchoMail will always run before Linkmessages.

    Yes, as it should. Linking messages before importing wouldn't make any sense!

    --- Mystic BBS v1.12 A11 (Windows)
    * Origin: Sector 7 [Mystic BBS WHQ] (46:1/127)
  • From Gryphon@46:1/116 to g00r00 on Tuesday, April 12, 2016 16:44:28
    On 04/12/16, g00r00 said the following...

    The logs don't show which messages were linked with which. It only shows how many messages were linked.

    Okay so you are saying it shows them linked in the logs but they're not linked in the message bases?

    Correct. The only linked message I can ever see are ones that are generated locally. No tossed FTN messages ever appear to be linked. Otherwise, each message shows with 'linked to' and 'refer to' as '0'.



    BUT, it appears for my case, from my logs, that the ImportEchoMail wi always run before Linkmessages.

    Yes, as it should. Linking messages before importing wouldn't make any sense!

    Does the linking process only work on newly tossed messages? If you ran the linkmessages all by itself, without tossing any messages? What would it do?

    "No matter where you go, there you are!" - Buckaroo Bonzai

    --- Mystic BBS v1.12 A10 (Raspberry Pi)
    * Origin: Cyberia BBS | Cyberia.Darktech.Org | Kingwood, TX (46:1/116)
  • From Gryphon@46:1/116 to g00r00 on Tuesday, April 12, 2016 16:53:06
    On 04/12/16, Gryphon said the following...

    On 04/12/16, g00r00 said the following...

    The logs don't show which messages were linked with which. It o shows how many messages were linked.

    Okay so you are saying it shows them linked in the logs but they're n linked in the message bases?

    Correct. The only linked message I can ever see are ones that are generated locally. No tossed FTN messages ever appear to be linked. Otherwise, each message shows with 'linked to' and 'refer to' as '0'.



    BUT, it appears for my case, from my logs, that the ImportEchoMa always run before Linkmessages.

    Yes, as it should. Linking messages before importing wouldn't make a sense!

    Does the linking process only work on newly tossed messages? If you ran the linkmessages all by itself, without tossing any messages? What
    would it do?

    More info:
    When I replied to your message, the "Refer To" value &7 was 0 and also the
    "See Also" value &8. But once I replied to the message, the &8 value updated to show it's own index number. But the &7 value remained as 0. My reply message did show the &7 value as linking to the original message, but the &8 value showed 0.

    "No matter where you go, there you are!" - Buckaroo Bonzai

    --- Mystic BBS v1.12 A10 (Raspberry Pi)
    * Origin: Cyberia BBS | Cyberia.Darktech.Org | Kingwood, TX (46:1/116)
  • From g00r00@46:1/127 to Gryphon on Wednesday, April 13, 2016 20:55:30
    Does the linking process only work on newly tossed messages? If you ran the linkmessages all by itself, without tossing any messages? What
    would it do?

    It links any message that doesn't have any link information defined for it, if there is data available to do so.

    Just to clarify terminology and codes here:

    &7 = Reply To
    &8 = Reply First
    &11 = Reply Next

    --- Mystic BBS v1.12 A11 (Windows)
    * Origin: Sector 7 [Mystic BBS WHQ] (46:1/127)