• Yet another Mystic python issue. Eyes, pls?

    From paulie420@21:2/150 to All on Tue Apr 26 19:21:51 2022
    I'll try to keep it short(ish).

    Originally, I had my Python2 and Python3 Mystic paths set to NULL and my Python2 scripts (RCS-pause, IBOL, xqtr-RSS, etc etc etc) ran fine. I wanted to use pn-dropfile, so I added 'libpython3.7m.so.1.0' to the Mystic Python3 path. pn-dropfile (Python 3 scripts) ran fine... but the Python2 scripts stopped working. If I add 'libpython2.7.so.1.0' to the Mystic Python2 path, user is disconnected when Python2 scripts run. Logs show:

    2022.04.26 18:41:02 An error has occured: EAccessViolation Access violation 2022.04.26 18:41:02 Shutting down

    Heres my 'ldconfig -p|grep libpython':
    paulie@bbs:~/mystic/logs $ ldconfig -p|grep libpython
    libpython3.7m.so.1.0 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libpython3.7m.so.1.0
    libpython3.7m.so (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libpython3.7m.so
    libpython2.7.so.1.0 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libpython2.7.so.1.0
    libpython2.7.so (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libpython2.7.so

    Heres my 'ls -all' of /usr/lib/arm-linux-gnueabihf:
    paulie@bbs:~/mystic/logs $ ls -all /usr/lib/arm-linux-gnueabihf/libpython* lrwxrwxrwx 1 root root 54 Oct 10 2019 /usr/lib/arm-linux-gnueabihf/libpython2.7.a -> ../python2.7/config-arm-linux-gnueabihf/libpython2.7.a
    lrwxrwxrwx 1 root root 17 Oct 10 2019 /usr/lib/arm-linux-gnueabihf/libpython2.7.so -> libpython2.7.so.1
    lrwxrwxrwx 1 root root 19 Oct 10 2019 /usr/lib/arm-linux-gnueabihf/libpython2.7.so.1 -> libpython2.7.so.1.0
    -rw-r--r-- 1 root root 2940952 Oct 10 2019 /usr/lib/arm-linux-gnueabihf/libpython2.7.so.1.0
    lrwxrwxrwx 1 root root 60 Jan 22 2021 /usr/lib/arm-linux-gnueabihf/libpython3.7m.a -> ../python3.7/config-3.7m-arm-linux-gnueabihf/libpython3.7m.a
    lrwxrwxrwx 1 root root 18 Jan 22 2021 /usr/lib/arm-linux-gnueabihf/libpython3.7m.so -> libpython3.7m.so.1
    lrwxrwxrwx 1 root root 20 Jan 22 2021 /usr/lib/arm-linux-gnueabihf/libpython3.7m.so.1 -> libpython3.7m.so.1.0
    -rw-r--r-- 1 root root 4325388 Jan 22 2021 /usr/lib/arm-linux-gnueabihf/libpython3.7m.so.1.0

    I just can't figure it out. I've tried adding all the libpython.x names in Mystic Python2 path - and none work. They all show 'Failed to initialize Python', except for libpython2.7.so.1.0 (which Mystic asks for...), which throws that EAccessViolation and shuts down.

    The real kicker here is... I was like OK - I wanted to use pn-dropfile, but my bbs is broken now so lets go back to 'original' - which was NULL in both Mystic Python paths... but when I do, NO Python scripts run. They all just 'Failed to initialize Python'.

    So I uninstalled ALL Pythons and reinstalled ALL of them - and the extra pip add-ons... OMG. Still the same. I checked the Mystic wiki and tried adding a symlink to /usr/lib - which 'worked', but still throws the EAccessViolation and shut down...

    I compiled g00r00's Python2.7 thats listed in the Mystic wiki: http://wiki.mysticbbs.com/doku.php?id=python_install
    (all the way at the bottom)

    It installed in /usr/scr - but... I dunno if I need to remove the original (re-installed) Python2.7/Python2/etc...

    I looked at permissions, and the pythonlib* files are root:root - I do run Mystic as 'paulie', but... the libpython3.7m.so.1.0 works just fine; and libpython2.7.so.1.0 looks to have the same symlinks and permissions.

    I'm pulling my hair out. More eyes on it will help... any ideas team BBS? :P


    --- Mystic BBS v1.12 A48 2022/04/03 (Raspberry Pi/32)
    * Origin: 2o fOr beeRS bbs>>>20ForBeers.com:1337 (21:2/150)